IDE
시작하기 - Windows
Windows OS 환경에서의 TESTSQUARE IDE 설치 및 실행, 메뉴바 기능 그리고 모바일 디바이스 설정 과정에 대한 설명을 제공합니다.
IDE 설치 및 실행
- TESTSQUARE 설치 파일 실행 후 [다음>] 버튼을 클릭합니다.

- IDE 설치를 진행하려면 사용자는 사용권 계약 동의 사항에 반드시 동의해야 합니다.

- 설치를 원하는 경로를 선택합니다. 특정한 디렉토리에 설치를 원할 경우 이 단계에서 지정할 수 있습니다.
IDE를 설치하려는 디스크의 여유 공간을 확인합니다. 충분한 공간이 없을 경우 필요한 조치를 취한 후 설치를 진행합니다.

- [설치] 버튼을 클릭하여 설치 프로세스를 시작합니다. 설치 진행 중에는 다른 작업을 수행하지 않도록 주의합니다.


- 설치가 완료된 후, TESTSQUARE 실행 여부를 선택할 수 있습니다.
"TESTSQUARE 실행하기" 옵션을 체크하고 [마침] 버튼을 클릭하면 IDE 프로그램이 자동으로 실행됩니다.

Menubar 구조 및 기능
IDE는 메뉴바를 통해 사용자가 솔루션을 더 효율적으로 활용할 수 있도록 다양한 기능을 제공합니다. 메뉴바는 네 가지 메뉴 항목으로 구성되어 있습니다.
- File
- Project
- Settings
- Help

File
File 메뉴는 IDE의 실행 및 종료와 관련된 주요 기능을 담고 있으며, 이 메뉴에는 아래와 같은 세 가지 하위 메뉴가 있습니다.

| No | 메뉴 | 설명 |
|---|---|---|
| 1 | Reload | 현재 화면 새로고침 |
| 2 | Logout | 현재 사용자의 접속을 종료하고 로그인 화면으로 이동 |
| 3 | Exit | IDE 종료 |
Project
Project 메뉴에는 프로젝트 관련 기능을 제공합니다.

| No | 메뉴 | 설명 |
|---|---|---|
| 1 | List | 프로젝트 목록 화면으로 이동 |
Settings
Settings는 IDE 사용 시 필요한 설정 정보 관리 기능을 제공합니다.

| No | 메뉴 | 설명 |
|---|---|---|
| 1 | Application | IDE 사용을 위한 필수 옵션 값 설정과 대시보드 URL 설정 기능 제공 |
| 2 | Alarm | 사용자에게 필요한 알림 발송을 위한 옵션 값 설정 기능을 제공 |
| 3 | 이메일 알림 발송을 위한 SMTP 정보를 설정(SMTP: 이메일을 대신 발송할 수 있도록 해주는 설정으로, 해당 SMTP 사용을 위해 사용자 이메일 계정에 SMTP 사용이 설정되어 있어야 합니다.) |
Help
Help 메뉴는 사용자가 IDE를 보다 효과적으로 활용할 수 있도록 도움을 줍니다.

| No | 메뉴 | 설명 |
|---|---|---|
| 1 | Information | 현재 사용 중인 IDE 프로그램에 대한 기본 정보 제공 |
Mobile Device 설정하기
모바일 테스트 스텝 생성 및 테스트 실행을 위해서는 PC에 연결된 대상 디바이스를 선택해야 합니다. 대상 디바이스를 선택하기 위해 USB를 통해 PC에 연결된 디바이스에 대한 사전 설정 작업이 필요합니다.
- 디바이스 개발자 옵션 활성화
- USB 디버깅 활성화
Device 개발자 옵션 활성화
Android 기반의 디바이스에 해당되며, 모델이나 OS버전에 따라 달라질 수 있습니다.
- '설정' 앱을 엽니다.
- 설정 메뉴에서 '휴대전화 정보' 메뉴를 클릭 합니다.

- '소프트웨어 정보'를 클릭합니다.

- '소프트웨어 정보' 메뉴에서 '빌드번호' 항목을 5회 이상 빠르게 클릭합니다.

- 클릭에 따라 '개발 설정 완료 N(1~4)단계 전입니다'와 같은 메시지가 나타나며 성공적으로 개발자 모드가 활성화 되었을 때 아래와 같은 문구가 노출됩니다.
디바이스 보안이 활성화된 상태에서는 보안을 해제하기 위한 창이 표시됩니다. 보안이 성공적으로 해제되면 개발자 모드가 활성화됩니다.

- 개발자 모드가 활성화 된 후 다시 설정 화면으로 돌아가면, '개발자 옵션' 메뉴가 생성되어 있습니다.

USB 디버깅 활성화
개발자 모드가 성공적으로 활성화 되고 나면 '설정'에 '개발자 옵션' 메뉴가 나타나고 '개발자 옵션' 메뉴로 이동하여 USB 디버깅을 활성화합니다.
- '개발자 옵션' 메뉴를 클릭하여 개발자 옵션 사용 중을 확인합니다.

- '개발자 옵션' 메뉴에서 USB 디버깅 옵션을 찾아 활성화합니다. 앱을 테스트하고 디바이스를 컴퓨터에 연결할 때 필요한 옵션입니다.

- USB 디버깅 버튼을 누르면 아래와 같은 팝업이 노출되며 [확인]버튼을 클릭하여 USB 디버깅을 허용합니다.
'이 컴퓨터에서 항상 허용'이 있을 때, 항상 허용 권장
